XA2 and ivonaTTS

  • ich versuche das TTS zum Laufen zu bekommen, aber es hakt ein wenig.


    TTS von google (com.google.android.tts) funktioniert soweit, ist aber leider

    nicht sehr zuverlässig. Nach einer Weile stoppt es einfach.


    Ich möchte IvonaTTS installieren. Die apks sind da, doch leider werden die

    Stimmen nicht gefunden. Auf meinem normalen Android (11) funktioniert

    alles super. Ivona-apks installiert und die Stimmen in den Gerätespeicher

    nach Android/obb kopiert. Fertig.


    Beim XA2 will mir das aber nicht gelingen, seit Stunden versuche die Kram

    zum Laufen zu bekommen.


    Mit logcat kann man es auch gut verfolgen, dass die Stimmen nicht gefunden

    werden. Wieso, ist mir nicht klar. Wo ist also der passende Ort in aliendalvik

    dafür? Alles mögliche hab ich ausprobiert.


    Hat irgendwer dieses Setup erfolgreich zum Laufen bekommen mit IvonaTTS?


    parts of my logcat here:
    I TextToSpeech: Sucessfully bound to com.ivona.tts
    I TtsEnginePrefFragment: Success
    I TTSServiceActivation: start
    I TextToSpeech: Connected to ComponentInfo{com.ivona.tts/com.ivona.ttslib.ics.IVONATextToSpeechService}
    I TextToSpeech: Set up connection to ComponentInfo{com.ivona.tts/com.ivona.ttslib.ics.IVONATextToSpeechService}
    D TtsEnginePrefFragment: Updating engine: Successfully bound to the engine: com.ivona.tts
    E IVONATTS: Cannot load voice junction.
    V SettingsProvider: Notifying for 0: content://settings/secure/tts_default_synth
    W DevicePolicyManager: Package com.ivona.tts (uid=10062, pid=1781) cannot access Device IDs
    W TelephonyPermissions: reportAccessDeniedToReadIdentifiers:com.ivona.tts:getDeviceId:isPreinstalled=false:isPrivApp=false


    Sailfish OS 4.1.0.24 (Kvarken) [Xperia XA2 (AOSP)] [aosp_h3113]