[Gelöst] Update auf Kvarken 4.1.0.24 schlägt fehl. Mehrfach.

  • Liebe Freunde des besten Systems ever,


    seit ca. 1,5 Wochen werde ich als "late adaptor" informiert über eine neue Version.


    WLAN zuhause, Ladegerät 'rein, 1x lief der Download, meine ich, die Installation schlug jedoch fehl. Anschließend versuchte ich es mehrfach, Abbrüche... doch die Meldung wird ständig angezeigt. Neustart wirkungslos. Hab's irgendwie geschafft, den Cache zu leeren. Neustart. Ohne Effekt. Ist nun acht Tage her - und die Meldung nervt :P, weil sie in der Event-Ansicht natürlich ganz oben steht. Außerdem will ich ja das Upgrade einspielen.


    Suche im EN Forum bisher erfolglos.


    Nutze aktuell 4.0.1.48 (Koli) und möchte upgraden auf 4.1.0.24 (Kvarken).


    Hat jemand Ideen, wie ich SF OS zu seinem Glück "zwingen" kann?

  • Hi,


    hast Du sonst alles bedacht, was in den Upgradeanweisungen von Jolla als Upgradevoraussetzungen geschrieben steht (Platzbedarf, sehr wenige Apps vorher deinstallieren, falls vorhanden)? -> Link

    Ich hatte ja dieses Mal auch Probleme mit dem Upgrade-Script (Link) das System auf eine neue Version zu heben. Im Jolla-Forum wird aber auch dieses Script genannt, wenn das ursprüngliche Upgrade nicht funktioniert.

    Wenn es auch damit nicht klappt, dann lädt er nur die ganzen Dateien runter (müsste auch im Cache stehen) und hört dann auf.

    Wenn gar nichts funktioniert, dann hilft nur noch diese Methode. Habe ich aber auch noch nicht praktiziert.


    -volker-

  • Da hab ich ja eventuell nur Glück gehabt. Allerdings hab ich dem Smarti gesagt, dass wenn es Ärger gibt LineageOS drauf kommt. Das mus irgendwie angekommen sein. Das Update war blitzschnell geladen, installiert, Neustart und alles was ich so im Augenblick benutze lief.


    Ich halte es für ein kleines Wunder....

  • Wollte kürzlich noch Bilder sichern. Liegen auf dem XA2 auf der SD-Card. Nachdem Übertragen per USB seit einer Weile zickt, nutzte ich dafür SSH über den Entwicklermodus.


    Tja, solange mein Mobiltelefon im Nirvana zwischen Produktivsystem und Upgrade hängt, kann ich den Entwicklermodus nicht aktivieren. Startet zwar, dauert jedoch ewig und ich breche dann ab.


    (Ja, zur Not könnte ich die SD-Karte physikalisch aus dem Handy ziehen, an einen Rechner anstöpseln und auslesen. Aber - 21. Jahrhundert, echt jetzt :/?! Möchte das vermeiden und die Zeit lieber in die Aktualisierung investieren. Risiko bleibt, ist aber geringer, als wenn die Bilder auf dem Gerät selbst lägen.)

  • Leider ist diese Veränderung nicht persistent - will sagen: Nach einem Reset oder einem erneuten Flashen des OS ist wieder die alte Aufteilung vorhanden. So jedenfalls wird es im Jolla-Forum kommuniziert -> Link


    -volker-

  • Hi Volker S, welchen Terminal benutzt Du hier?

    sfos-upgrade?

    Mit der "App" ToeTerm komme ich nicht weiter. Und der Terminal, den der Entwicklermodus bietet, erreiche ich nicht, weil... siehe oben: Der Entwicklermodus nicht so recht starten mag.


    Neustart wirkungslos.


    (Will hier keinen 1:1-Support :saint:, aber irgendwie vorankommen).


    [Edit: Man = ich sollte verlinkte Beiträge von oben nach unten lesen - und zwar von gaaaaaaaaaanz oben. Frage hat sich erledigt, ich versuch's via sfos-upgrade. /Edit]

  • Zitat

    Leider ist diese Veränderung nicht persistent - will sagen: Nach einem Reset oder einem erneuten Flashen des OS ist wieder die alte Aufteilung vorhanden. So jedenfalls wird es im Jolla-Forum kommuniziert -> Link

    Ja, das ist vielleicht ne gute Anmerkung. So ist das ja auch gewollt, beim einem Reset. Ich finde aber, das kann man schon -irgendwie- vernachlässigen, denn wie oft man denn einen kompletten Reset oder NewFlash? Wenn es jede kommende SFOS-update auch betreffen würde, dann wäre das sicher übel.

  • @spheniscus,

    ...wenn gar nichts mehr geht, hilft wohl nur neu flashen. Ich habe bisher nur Upgrades gefahren. 3x (oder warens schon 4x?) mit sfos-upgrade und einmal mit dem vom SFOS angebotenden Upgrade (weil das letzte Mal sfos-upgrade nur alle Dateien runter geladen hat, aber die Installation dann verweigerte).


    Mit der Version 4.0 war ich vollkommen zufrieden - mit 4.1 nicht mehr so. Aliendalvik startet (laut Forum ist das ein Bug) zu schnell und man muss Aliendalvik manchmal manuell deaktivieren/aktivieren. Das wird wohl bei der nächsten Version wieder gefixt.


    Bleibt noch mein erhöhter Strombedarf, wenn ich WLAN benutze - und eine News-App will leider auch nicht mehr so recht mit der 4.1 (geht zu 90% nach dem Starten sofort in den Hintergrund).

    Könnte vielleicht auch an der vermurksten Aliendalvik-Einbindung liegen.


    ...selbst das manuelle Aktivieren von AD (nach dem manuellen Deaktivieren) dauert oft viel länger als normal. Ich hoffe, dass ich das nächste Upgrade wieder normal einspielen kann (also mit sfos-upgrade) und ich nicht neu flashen muss.


    -volker-

  • Aber - 21. Jahrhundert, echt jetzt?!

    Wir haben sogar schon das 26. Jahrhundert ... nach buddhistischer Zeitrechnung.

    Zeit(rechnung) ist eine Illusion. Die Moslems leben im 15. Jahrhundert und haben schon Mobilfunk, moah sind die Fortschrittlich, da haben wir noch Pergament bemalt. ;)

    Insofern: ja, echt jetzt!

    SCNR

  • Flashen? Puuh. Möchte ich tunlichst vermeiden. Klar hätte das eine "bereinigende Wirkung". Dennoch...

    26. Jahrhundert ;-)? Umso schlimmer.


    OpenRepos zerschossen. Jolla-Account funzt zwar als LogIn per Web - zeigt mir jedoch im Store am Handy keine Apps an, was so nicht stimmt, da ich einige native Jolla-Apps nutze. Heißt also:

    • Update schlägt fehl
    • DEV mode schlägt fehlt, folglich kein Terminal, was alle anderen Hinweise/Versuche mindestens erschwert bis unmöglich macht
    • Jolla-Account zerschossen, wie auch immer ich (?) oder das System (?) das hinbekommen hat

    Lange Rede, kurzer Sinn: Ich komme mit meinen Mitteln und Fähigkeiten nicht weiter. Habe eine Anfrage via Formular an den Jolla-Support gestellt: "Update to Kvarken 4.1.0.24 fails multiple times. Jolla account broken. No DEV mode/Terminal on XA2"


    Wieder einmal: Melde mich.

  • Flashen? Puuh. Möchte ich tunlichst vermeiden. Klar hätte das eine "bereinigende Wirkung".

    .....

    Lange Rede, kurzer Sinn: Ich komme mit meinen Mitteln und Fähigkeiten nicht weiter.

    Es ist wie immer: Kein Backup -> kein Mitleid.

    Nur wird es einem beim SailfishOS echt nicht leicht gemacht, ein funktionierendes und entsprechend leicht einzuspielendes Backup anzufertigen. Leider.


    Ich würds an Deiner Stelle wohl neu flashen und zudem über eine mögliche Backup-Strategie nachdenken. Selbst wenn Du das update jetzt doch noch drauf bekommst, ist das Gewusel von vorher ja nicht weg, sondern wuselt danach eben mit aktuellerer Software... :)

  • Hi clicks , danke Dir. Schon klar, kein BackUp, kein Mitleid, sage ich auch immer. Den anderen. ;)


    Mir geht es nicht um BackUp. Wie ich die (für mich) "wesentlichen" Daten vom Gerät 'runterbekomme, weiß ich. Geht eher darum, dass das Plattmachen und vor allem: Wieder aufspielen, Apps installieren, konfigurieren, einrichten schlichtweg Zeit :sleeping: kostet - die ich an anderer Stelle gerade besser gebrauchen kann.


    Mit Bereinigen meine ich: Frisches System (nicht: Meine Daten). Gewusel beseitigt. Apps, die ich nicht (mehr) nutze, dümpeln nicht mehr mit irgendwelchen Resten herum. Evtl. läuft's flüssiger. Hätte durchaus Vorteile, ja. Andererseits zerlege ich nur dann die Karosserie meines Fahrzeugs bei laufender Fahrt, wenn es absolut notwendig ist.


    Will dennoch die Rückmeldung aus Finnland abwarten. Eine liebevolle Support-Anfrage kann - muss nich' 8o - durchaus für die Entwickler hilfreich sein.


    [Edit: Volltreffer am 23. Juli, genau die Urlaubswoche erwischt. Jolla Zendesk autoreply meldet "...

    Please note that during our summer holiday season (July - August) our response time may be even longer. We are closed from July 17th until July 25th, 2021..." Naja, noch tut's ja, solange ich alles unverändert lasse. Ist wie balancieren auf rohen Eiern. /Edit}

  • Hi clicks , Schon klar, kein BackUp, kein Mitleid, sage ich auch immer. Den anderen. ;)


    Mir geht es nicht um BackUp. Wie ich die (für mich) "wesentlichen" Daten vom Gerät 'runterbekomme, weiß ich. Geht eher darum, dass das Plattmachen und vor allem: Wieder aufspielen, Apps installieren, konfigurieren, einrichten schlichtweg Zeit :sleeping: kostet - die ich an anderer Stelle gerade besser gebrauchen kann.

    Der erste Satz war wirklich gut!


    Bei einem Backup geht es grundsätzlich ja nicht nur darum, dass man Daten "runterbekommt", sondern dass man sein System eben wieder herstellen kann.


    Du schreibst von plattmachen, aufspielen, apps installieren und konfigurieren ...usw vielleicht ist sowas ja gar nicht wirklich notwendig?


    Vielleicht ist das ja der mühselige Weg und es ginge besser? Du könntest ja auch an einem Punkt, wo Du sagst, dass Dir der momentane Systemstand gut gefällt, ein FullBackup ziehen. Du machst also ein Image vom gesamten System am 20. Juli. Ne Woche später geht irgendwas in die Grütze und Du packst die Vollsicherung wieder drauf + die inzwischen evtl. neu dazu gekommenen Daten. Ist also schmerzfrei, denn während das Backup zurückgespielt wird, kannst Du auch den Rasen mähen, "verlierst" also eigentlich keine Zeit.


    Beim xa2 sind eigentlich nur zwei Partitionen wirklich interessant, die man komplett sichern (z.B. mit dd oder rsync) muss. Je nachdem, wie fein strukturiert Deine Massnahmen dann sind ist eine Wiederherstellung kein Drama.

  • :evil:Danke für die Blumen.


    Technisch sind gute Hinweise dabei. Allerdings zwei Gegenfragen:

    • Wie erstellst Du ein BackUp, wenn Du per Telefon den Entwicklermodus am Gerät nicht (mehr) starten kannst - und damit SSH entfällt?
    • Wie gehe ich mit DestroyDisk ;) oder egal was auf die Partitionen des Geräts los, wenn ich per USB nicht verbinden kann? (Daran hab' ich mich inzwischen gewöhnt.)
      Wobei - halt, abgesicherter Modus, Recovery Mode, da war doch was, richtig?

    Merke gerade, ich/wir schweifen gerade bisserl vom eigentlichen Thema Update ab in Richtung BackUp-Konzept. Wäre 'nen eigenen Eintrag wert, oder zwei...

    • Wobei - halt, abgesicherter Modus, Recovery Mode, da war doch was, richtig?

    Recovery-Mode ist wirklich einfach:


    fastboot boot hybris-recovery.img
    telnet 10.42.66.66


    siehe: https://jolla.zendesk.com/hc/e…-to-use-the-Recovery-Mode


    Hast recht, das hilft jetzt auch nicht wirklich bei deinem Update-Problem, jedoch kann man manchmal dann auch ein wenig aggressiver mit den Optionen vorgehen, solange das packende Backup vorhanden ist...


    Kannst ja mal im recovery nen filesystem-check machen :saint:

  • UPDATE: Jolla Customer Care (JCC) / zendesk reagierte gestern 26.7. auf meine Anfrage vom 23.7. Über's Wochenende und trotz Urlaubszeit (deren Autoresponder) eine ganz passable Reaktionszeit, wie ich finde.


    Drei Punkte:

    1. Update: Offen
    2. Jolla account zerschossen: Man empfahl mir, den Account zu löschen am Handy. Reboot. Konto verbinden - bestehendes wählen. OK, funzt, Dann möge ich irgendeine App aus dem Store installieren. Beim Öffnen des Stores: "Problem mit dem Store. Bei der App-Registrierung ist ein ernsthaftes Problem aufgetreten." App-Installationen versucht, rödelt, tut sich letztlich... nix. - JCC versprach, meinen Account im Backend zu prüfen.
    3. Terminal: JCC schätzen die Chancen als "weak" ein. Offen.

    So, wie ich das verstehe, ist für ein Update ein funktionierender Jolla-Account nötig. Insofern pausiere ich erneut, bis ich Antwort aus Finnland erhielt. Schätze, auch ein Flashen oder RecoveryMode wird früher oder später auf ein Jolla-Konto hinauslaufen.

    Wie auch immer (ich?!) das zerschossen habe.

    Klar könnte ich ein neues Konto anlegen - aber das ist m.E. kaum die Lösung.


    Fotos von der SD-Karte händisch gezogen. (Ja, ich weiß, die sollte ein Update etc. in Ruhe lassen - dennoch: Sicher ist sicher.)


    Melde mich...