Suche in PureMaps geht nicht mehr

  • Guten Tag,


    die Suche in PureMaps bringt grundsätzlich keine Ergebnisse mehr, sodass mir die Navigationsmöglichkeit abhanden gekommen ist. Außer Updates für Apps habe ich am OS nichts geändert. In OSM Scout funktioniert die Suche problemlos, aber das Programm ist nicht zum Routing gedacht und hat so seine Macken beim Nutzen der Karte. Was mir noch aufgefallen ist: Wenn ich die App OSM Scout Server starte, dann steht auf dem Startbildschirm "inaktiv" im kleinen Fenster.


    Ich nutze S OS 3.2 .10 - ein Upgrade kann ich erst durchführen, wenn ich mich eingelesen habe und dann Tage habe, wo ich notfalls Probleme mit eurer Hilfe lösen kann und nicht auf das Gerät zwingend angewiesen bin - auf Xperia 10 Dual Sim.


    Grüße


    Basel

  • Hallo Basel, deine beschrieben Problem mit Pure Maps kann ich nicht Bestätigen ich nutze die App schon lange und hatte seit langen keine Störungen mehr. Ich habe zu einem ein Sony XAII Dual Sim SFoS 4.0.1.48 und Pure Maps 2.6.5-1.16.11jolla. Früher waren manchmal aus Setzer bei der Anzeige der Aktuellen Verkehrs Info wo halt stau ist das ist aber behoben. Was schneller gehen könnte ist die GPS Satelliten Erfassung das liegt aber bei mir daran das ich nur das Native GPS gerät benutze und nicht andere quellen wie Sim-Karten daten, Wlann … da bin ich mir sicher wer und was da liest. Ist halt mein persönlicher splin. Das andere Gerät ist eine Sony X10 das ist auch auf dem Aktuellen stand beim OS und App und geht ohne Problem.

  • Ist der OSM Scout Server bei dir auch inaktiv? Danke für deine Antwort.

    Hallo wenn der nicht im PureMaps intergiert ist dann nicht denn extra installiert habe ich denn nicht. Wo es mal Probleme gab da waren die falschen API-Keys eingetragen das ist aber schnell behoben worden mit eine Update. Das könnte es natürlich bei dir auch sein dann kann die App nicht auf die Datenbanken zugreifen grob gesagt.

  • Ich habe den OSM Scout Server auch nicht installiert, den OSM Scout (der gerade ein Update erhalten hat) aber schon. Ich meine das stand bei der Offline-Benutzung des PureMaps auch dabei, dass er dann zwingend erforderlich ist.

    Wenn man nur mit den Onlinekarten unterwegs ist, dann natürlich nicht.


    -volker-

  • Also hier meine Anleitung von der Installation. Ja, den OSM Scout-Server habe ich wegen der Offline-Navigation installiert. Aber ich habe auch mit Netz-Verbindung das Problem, dass keine Adressen mehr gefunden werden.

    Hallo Basel das klingt mir recht nach einem falschen verweis der API`s das hat es wie oben schon beschrieben bei einer Version gegeben. Ich habe das auch schon bei anderen Apps gehabt entweder man kennt die genauen Adressen und trägt sie selbst ein oder es gibt ein Update dafür. Das ändern geht zum Teil ja nach App in den Einstellungen oder ich muss das in der Entsprechenden Datei über das Terminal und Editor mit Root-rechten tun. Dann sollte das wieder funktionieren oder du wendest dich z.B. über Storemann direkt an den Entwickler oder sucht dort in den Beiträgen meist findet man da schon was. Meist sind das nur Syntax Fehler beim schreiben der App getreu dem Motto "wer Rechtschreibefehler findet darf sie behalten" ;)

  • Hallo,

    nach dem Update auf SOS 4 konnte ich den Harbour Storeman wieder installieren und darüber Pue Maps aktualisieren. Dafür musste ich im Storman die Quelle erst einmal wieder aktivieren.

    Grüße

    Basel

  • Hallo,

    nach dem Update auf SOS 4 konnte ich den Harbour Storeman wieder installieren und darüber Pue Maps aktualisieren. Dafür musste ich im Storman die Quelle erst einmal wieder aktivieren.

    Grüße

    Basel

    Na das klingt doch gut. Manchmal nervt das gewaltig das es solche Kleinigkeiten nicht funktionieren aber die Alternativen nerven mich mehr und bei denen läuft auch nicht immer alles sauber nur wird nie so eine Buhei drum gemacht.

  • Hallo,


    es geht weiter mit den Problemen. Doof, wenn solche Probleme auffallen, wenn man die Navigation dringend braucht.


    Wenn man die App startet, kommt eine Fehlermeldung.


    Bildschirmfoto_20220101_001.png


    Ich habe OSM Scout als Karte ausgewählt. OpenTopMap hingegen geht; HSL OpenSlope und Sputnik ergeben weiße Seiten. Here und Mapbox ergeben das selbe Luftbild.


    Wenn ich OSM Scout als App starte und auf "Wo befinde ich mich?" auswähle, kommt ebenfalls ein Fehlermeldung: "Seite konnte nicht geladen werden". Auf der Karte ist der grüne Punkt an der richtigen Stelle (draußen) bzw. halbwegs an der richtigen Stelle (wenn ich im Haus bin). Und die Karte wird angezeigt (laut Einstellungen "Hide & Bike Karte" als Stil).


    Arrg, und ich habe keine Idee, wie das Problem zu lösen ist.


    Grüße


    Basel

  • Den Api-Key braucht du nur, wenn Du den Dienst von Mapbox (was dann gleichzeitig Deine Karteneinstellung ist) benutzt.

    Wenn Du bei Pure Maps den Dienst von OSM Scout benutzt (ich benutze nicht den OSM Scout Server), dann braucht man auch keinen API-Key eingeben.


    Allerdings hat sich auch bei mir etwas verändert. Ich kann mein Pure Maps unter den Profilen nur "Online" oder "gemischt" eingeben. Nur dann findet er die gesuchten Ziele (geprüft unter Mapbox mit Api-Key und unter OSM Scout als Karte).

    Der Fehler trat dann zwar auch auf:

    Fehler_PureMaps.jpg

    ...aber die Ziele wurden gefunden und geroutet.


    Wenn ich allerdings das Profil "Offline" gewählt hatte, dann findet er kein Ziel mehr und das Navi ist dann zwecklos.

    Dieses Ergebnis habe ich mit GPS aktiv (individuelle Einstellung: GPS + Mozilla-Offline-Positionsbestimmung).

    Dieses ist sehr merkwürdig, weil das meine Standardeinstellung war - da der OSM Scout ja die Offline-Karten mitbringt.

    Dieser oben eingeblendete Fehler kommt aber immer (nach so ca. 15 - 20 Sek), also auch bei den funktionierenden Modis unter dem Profil Online und gemischt.

    Vielleich muss man beim Profilwechsel auch Pure Maps neu starten, und der fehler wäre dann weg. Das habe ich nicht ausprobiert.

    Vielleicht wird es mal Zeit eine andere Navi-Soft zu installieren?


    -volker-

    - Frickelphone (XA2 Plus mit Sailfish)

    - Lumia 930 (Windows Mobile 10)

    Einmal editiert, zuletzt von Volker S ()

  • Naja, ich installiere mir dann lieber eine andere Navisoft. Dieses ganze mapbox-Gerödel braucht man nur beim online navigieren und von je her ist Pure Maps bei mir auf 'offline' gestellt.

    Und diese Profileinstellung funzt nun (bei mir) nicht mehr vernünftig.


    -volker-

  • Es gab im November ein update welches sich mit API-Keys beschäftigt . Die musst du dann einrichten . Hast du das damals geladen (open repos) ?

    Ich hatte zuletzt am 26.12. alles aktualisiert, heute dann nochmal. Ich nutzte nichts mit API-Key.

    Dieser oben eingeblendete Fehler kommt aber immer (nach so ca. 15 - 20 Sek), also auch bei den funktionierenden Modis unter dem Profil Online und gemischt.

    Vielleicht wird es mal Zeit eine andere Navi-Soft zu installieren?

    Bei mir verschwindet die Meldung nicht nach einiger Zeit.


    Die Auswahl an Apps mit Sprachausgabe für das Routing mit dem Rad ist überschaubar.

    Also mit längerer Suche hab ich folgendes gefunden : genau das selbe Problem hatte ein user im Sailfishosforum. Sein Problem wurde gelöst durch ein update des mapboxgl-qml über open repos. Versuch macht klug.

    s. vorherigen Post.


    Naja, ich installiere mir dann lieber eine andere Navisoft. Dieses ganze mapbox-Gerödel braucht man nur beim online navigieren und von je her ist Pure Maps bei mir auf 'offline' gestellt.

    So richtig klar ist mir gerade nicht, welchen Nutzen bzw. Vor- und Nachteile die drei Modi haben.

    ...hab jetzt auch Magic Earth von Aurora installiert. Bellini hat im Juli vorigen Jahres noch etwas vom Probebetrieb/Demo geschrieben (Link) - das scheint jetzt wohl nicht mehr der Fall zu sein.

    Durchgeschleifte Android-Apps sind für mich nur eine Notlösung.

  • Mag sein, dass es nur eine Notlösung sind. Wenn es unter SFOS genauso einfach einzurichten wäre, ein Traum. Here auf SFOS war ja auch eigentlich eine Notlösung, läuft nur nicht mehr vernünftig. Also benutze ich Magic Earth auf SFOS und in der Hauptsache auf LineageOS und bin zufrieden.

    Sony Xperia XA2 mit LineageOS 19.1
    Sony Xperia XA2 mit SFOS in der Schublade

  • So richtig klar ist mir gerade nicht, welchen Nutzen bzw. Vor- und Nachteile die drei Modi haben.

    Diesen Offline-Modus von Pure Maps interpretiere ich so, dass eine App, oder die Navi-App selber, die Navikarte offline - ergo auf dem Gerät - zur Verfügung stellt.

    Man braucht dann keine SIM-Verbindung. Für die Option gemischt wird die Karte offline zur Verfügung gestellt und aktive Meldungen (Staus usw.) per SIM bereit gestellt.


    -volker-