Android App starten nach update auf SFOS 3.3 nicht mehr

  • Nach dem Update auf SFOS 3.3 Rouka startete der Android support erst gar nicht mehr. Unter "Einstellungen => Andoid App Unterstützung " sprang der Button nach dem Starten auf Anhalten und direkt wieder zurück. Problem hier war das paket Alien-dalvik-Control, nach der Deinstallation startet der Andoid Support zumindest wieder. Nach dem Drücken des Start Button sprang der Button dann auf Anhalten. Somit denke ich das der Android Support wieder funktioniert.


    Aber wenn ich Android Apps starte, tauchsen diese dann in der Appübersicht auf, das ivon mit dem Kreis dreht und dreht sich und nach ein paar Sekunden schließt sich das kleine Fenster wieder.


    Was kann ich tun ? ich bin da gerade etwas ratlos, da ich keine Fehlermeldung nichts bekomme.


    Die Logs (https://together.jolla.com/que…lp-debug-android-support/) helfen mir auch nicht weiter da ich nicht weis wonach ich suchen soll ;(


    Auch in den Logausgaben steht nichts von Fehlern Andriod betreffend : https://jolla.zendesk.com/hc/e…t-Debugging-Android-apps-

  • Hast du nach dem Update das übliche:

    Code
    1. devel-su
    2. pkcon refresh
    3. pkcon update

    durchlaufen lassen?

    Auch ein erneutes

    Code
    1. version --dup

    kann nicht schaden.


    Was du danach noch versuchen kannst ist den aliendalvik, also die Androidunterstützung, einfach neu drüberzubügeln. Dazu reicht normalerweise ein einfaches

    Code
    1. devel-su
    2. pkcon install aliendalvik

    ohne vorher zu deinstallieren: Wenn eine Fehlermeldung kommt und es nicht installiert wird, ist die alte Dalvik noch drauf.

    Ich habe es gerade auf meinem X ausprobiert, ist durchgelaufen. Aber solche Tipps sind natürlich wie immer auf eigene Gefahr. Keine Ahnung wie ein offiziell nicht unterstütztes Gerät darauf reagiert.

  • gab es beim alien-dalvik paket updates ? Ich hatte das damals von einem andere Telefon genommen, da ich für das X Compact kein support erhielt, das dalvik paket habe ich noch und es lief bisher ohne probleme ( der android support startet ja auch )

    Code
    1. md5sum aliendalvik-1.0.82-1.armv7hl.rpm
    2. f84c02dcac75583ceb1806e97e14439b aliendalvik-1.0.82-1.armv7hl.rpm


    Der unterschied vom X zum X compact ist eigentlich nur im AOSP begründet und das ist ja unverändert, sprich die API etc sind nach wie vor die gleichen wie beim normalen Xperia X. Auch startet der Andoirs support aber eben die Apps nicht bzw. werden wieder beendet weil die Grafische Ausgabe nicht zu funktionieren zu scheint.




    Wo kann ich denn noch nach Fehlerlogs suchen bzw. welche Syntax/Fehlermeldungen sollte ich wo suchen ? Irgendwo muss doch eine Fehlerausgabe zu finden sein. Ich tippe auf eine Fehler irgendwo im Wayland Dalvik Zusammenspiel, da scheint was nicht rund zu laufen.

  • nach dem update ging der ganze Marktplatz-Kram auch nicht, wie f-droid, aptoid, usw.
    Nach paar Neustart-s ging es wieder.
    Nur findet man kaum Programme, die dort groß was taugen - auch unter openRepos
    nicht.
    Nur gut, dass die Standard-Programme oft ausreichen.
    Einzig opera-mini, UB-browser + k9 hat man installiert. Der nextcloud-Adlate tut auch nur halb-
    lebendig - da langt die ghost-cloud-dropbox-Kombi -
    einzig für N29 benötigt man noch einen extra device-androiden - sonst völlig unnöitg

  • nach dem update ging der ganze Marktplatz-Kram auch nicht, wie f-droid, aptoid, usw.
    Nach paar Neustart-s ging es wieder.

    Ich klemme mich hier mal mit ran, eventuell berührt das mein Problem auch.
    Situation ist die: neues Sailfish OS (als Phone gekauft im Store) im Jolla-Store aptoid zur Installation ausgewählt - Fehler, F-droid gleiches.
    Neustarts, Phone zurückgesetzt, alles schon mehrfach gemacht, kein Erfolg.

  • Ich bin auch grad am überlegen ob ich mein Xperia zurücksetzen soll, das Schlimme sind die nachträglichen Anpassungen, die ich gemacht habe ( root Partition vergrößert die ganzen Apps Einstellungen ( hat jmd mal die Backup App für die Appseinstellungen von Openrepos getestet ? ), bis das alles wieder läuft dauert es ewig :/ ).


    FrankD, hast du ein XA2 erstanden und dann die Sailfish OS 3.3 Installation aus dem Jollastore drauf und dann alien Dalvik installiert ? Wenn dem so ist und das mit dem XA2 die gleichen Probleme gibt wie mit dem Xperia X kann ich mir das XA2 sparen. Ich bin mit dem Xperia eigentlich gut zufrieden und habe etwas gegen immer neue Hardware wenn eine Neuanschaffung nicht wirklich zwingend ist. Aber SFOS Ohne Android ist noch nicht wirklich sinnvoll, es gibt für SFOS einfach keine brauchbaren nativen Browser ;/

  • FrankD, hast du ein XA2 erstanden und dann die Sailfish OS 3.3 Installation aus dem Jollastore drauf und dann alien Dalvik installiert ? Wenn dem so ist und das mit dem XA2 die gleichen Probleme gibt wie mit dem Xperia X kann ich mir das XA2 sparen. Ich bin mit dem Xperia eigentlich gut zufrieden und habe etwas gegen immer neue Hardware wenn eine Neuanschaffung nicht wirklich zwingend ist. Aber SFOS Ohne Android ist noch nicht wirklich sinnvoll, es gibt für SFOS einfach keine brauchbaren nativen Browser ;/

    Ich hab ein XA2 mit Sailfish 3.3, soweit richtig.
    Aber außer den ab Installation vorhandenen Apps noch nichts installiert, da mir nichts für mich sinnvoll erscheint.

  • Klapp denn die Installation der Android Apps oder gibt es da Fehler ? die Installation läuft hier sauber durch nur sehe ich keine der Apps. Lt Menu zum Starten und beenden der Android Umgebung läuft aliendalvik aber es wird eben nichts auf der Wayland Oberfläche dargestellt. das würde auch zu dem vorigen Fehler passen, bei dem die App startet, das kleine Fenster sich öffnet aber nach zig umdrehungen des "Ladeziekels" sich dann wieder schließt.

    Was ergibt denn ein "pgrep -a | grep alien" bei dir ?


    Bei mir scheint demnach der dalvik zu laufen.

  • Ich hab im Store nach kurzer Recherche im Inet nach "Alien" gesucht.
    Darufhin wurde mir der Android-Support, welcher unter Suchbegriff Android nicht auffindbar war, angeboten.
    Die Installation lief durch, nun ist auch der Aptoid installiert und zwei Android-Apps sind auf dem Phone installiert.
    Wie sie sich verhalten, weiß ich noch nicht.

  • Wie hoch sind deine Linux Skills ? ich denke mit der GUI kommen wir hier nicht weiter, zumal der Fehler erst einmal eingegrenzt werden muss. Ich habe das ganze mal unter together.jolla zusammengefasst : https://together.jolla.com/que…-update-to-sfos-33-fails/


    Wir scheinen nicht die einzigen zu sein bei denen der Android support nicht mehr will.

  • Wie hoch sind deine Linux Skills ? ich denke mit der GUI kommen wir hier nicht weiter, zumal der Fehler erst einmal eingegrenzt werden muss. Ich habe das ganze mal unter together.jolla zusammengefasst : https://together.jolla.com/que…-update-to-sfos-33-fails/


    Wir scheinen nicht die einzigen zu sein bei denen der Android support nicht mehr will.

    Ui, Linux-Skills...
    Ich weiß, was Linux ist.
    Kann mich in Konfigurationsdateien bewegen, das wars aber dann.
    Konsole oder ähnliches nur per c&p aus Vorlagen.

  • Hab dein "Statement" in nem anderen Thread gelesen. Wie sagt man so schön man lernt nie aus. Das tolle an Linux : Man lernt fürs Leben ( mit Linux ) und die Grundlagen auf der Shell sind für fast alle Linux basierten Systeme gültig - sogar für Router und Applesysteme.


    Aber die Konsole ist dir schon bekannt - das ist eine gute Basis und ausbaufähig ;)

  • Dann schiebe ich das Thema Update weiterhin vor mir her.

    Gute Idee! Ich würde das 3.3 Update auch nicht mehr installieren. Wenn nicht bald ein Update kommt, was meine Netzwerkproblem fixt, werde ich vll mal schauen, ob ich das OS mit 3.2 neu aufspiele. Das ist das erste Mal, dass ich von einem Update richtig angenervt bin. Dauernd das Netz zu verlieren ist einfach Mist.

  • Naja es ist eigentlich nur der Android support der nicht mehr will, auf meinem Jollaphone reist die Wlan Verbindung auch hin und wieder ab, auf dem Xperia Xc läuft bis auf den Androiden alles und auch stabil. Gibt viele kleine Änderungen, die ich schon lange vermisse ( Timer endlich auf für Sekunden einstellbar => Eieruhr 6:30 min Eier ;) Icons und Gui im Gesamteindruck schärfer, update der Shell Tools wie grep etc, Darstellung der Kontakte/Adressbuch Nextcloud support ( mit NC 15 allerdings gehts nicht)).