Jolla 1 - Update von 3.2.0.12 auf 3.2.1.20 startet nicht

  • Ich habe mein altes Jolla 1 eigentlich nur noch als Notfallgerät (seit 1,5 Jahren nutze ich ein Samsung S5 mit LineageOS), lade es dennoch regelmäßig auf und aktualisiere die Programme und das Betriebssystem.


    Nachdem ich Ende letzten Jahres festgestellt habe, dass die Version 3.2.1.20 (Nuuksio) zur Verfügung steht, habe ich versucht das Update zu installieren. Das Update wurde auch heruntergeladen, allerdings brach die Aktualisierung mit einer Fehlermeldung ab. Soweit ich mich erinnern kann, hieß es (sinngemäß): Kann derzeit nicht installiert werden, später nochmal versuchen.


    Das Jolla funktioniert weiterhin mit 3.2.0.12. Wenn ich versuche, die Systemaktualisierung zu wiederholen, komme ich nicht weiter: Zunächst heißt es "Aktualisierung zum Herunterladen verfügbar". Wenn ich "Herunterladen" wähle, erscheint mehrere Minuten "Auf Verbindung warten...", anschließend wieder "Aktualisierung zum Herunterladen verfügbar"!


    Gibt's da noch eine Möglichkeit - eventuell im Terminal - das Update noch zu installieren?

  • Also ich würde mit deiner aktuellen Version mal ein

    devel-su

    pkcon refresh

    pkcon update

    version --dup

    machen. Falls was nachgeladen wird das Gerät neu starten und einen Moment nutzen. Dann alle patches deaktivieren und danach:

    Code
    1. devel-su
    2. ssu re 3.2.1.20
    3. ssu ur
    4. version --dup
    5. sync
    6. reboot

    Alle Befehle einzeln nacheinander durchlaufen lassen.

    Hinter ssu re kommt immer die gewünschte Versionsnummer. Also die, auf die du updaten willst.

    Nach dem Neustart des Telefon mit der neuen Version bitte nochmal pkcon refresh und pkcon update als devel-su durchlaufen lassen. Dann ab zum nächsten Update. Wenn alles auf dem aktuellsten Stand ist die Patches wieder aktivieren, freuen, wenn einige noch funktionieren und SFOS genießen.

    Ich drück die Daumen, dass es durchläuft. Falls nicht, don't blame me :P

  • Vielen Dank für die prompten Antworten.


    Ich habe (nach einem vergeblichen Versuch am Jolla) heute per openssh nochmals die von dirksche empfohlene Methode versucht. Leider komme ich schon am Anfang nicht weiter:

    ,---

    | Sailfish OS 3.2.0.12 (Torronsuo)

    '---

    [nemo@Sailfish ~]$ devel-su

    Password:

    [root@Sailfish nemo]# pkcon refresh

    Refreshing cache

    Starting

    Finished

    Fatal error: /etc/zypp/repos.d/ssu_openrepos-llelectronics_release.repo: Section [openrepos-llelectronics]: Line 7 contains garbage (no '=' or ':/?|,\' in key)

    [root@Sailfish nemo]#


    Ich habe von Leszek Lesner (llelectronics) die Apps Webcat und LLs Video Player im Storeman, beide Apps funktionieren auch. Soll ich die beiden Apps löschen oder gibt es einen besseren Weg, das Problem zu lösen?

  • Für mich sieht das so aus als wenn da ein Repository quer sitzt. Das Deinstallieren wird wahrscheinlich alleine nichts bringen. Ich würde mal folgendes machen. Wenn du die Programme tatsächlich über Openrepos hast dann geh mal in Storeman in die Softwarequellen und deaktiviere oder lösche die Repos von LL. Hast du Storeman nicht drauf? Hast du vorher mit zypper gearbeitet statt pkcon? Dann versuchs mal mit der zypper Paketverwaltung ob du einzelne Repos löschen kannst. Hab mein X mit SFOS gerade nicht zur Hand.

  • Hallo, melde mich mal wieder...


    Ich habe mittlerweile die Anleitung von monkeyisland ausprobiert:

    Wie man sieht, bin leider nicht weitergekommen.

    Vielleicht hat noch jemand einen Tipp.


    (Ansonsten - falls nichts mehr hilft - habe ich noch ein Systemimage der Version 3.0.0.8, das ich im Januar 2019 gemacht habe und zurückspielen könnte.)

  • Hast du in Storeman versucht die Softwarequelle zu löschen?

    Ja, ich habe es aus den Softwarequellen "entfernt" (nicht deaktiviert). Seht jetzt so aus:

    Hast du es mal mit zypper removerepo versucht? Was passiert wenn du zypper refresh durchlaufen lässt?

    Hab' versucht, die Zypper-Tools nachzuinstallieren, vergeblich:

    Code
    1. [root@Sailfish nemo]# pkcon install zypper
    2. Resolving [ ] (0%)

    Hast du mal versucht LL direkt zu kontaktieren?

    Bisher noch nicht, wenn "nichts mehr hilft", werd' ich das noch machen.

  • Hallo dirksche,


    ich habe gestern spätabends den in Beitrag #8 verlinkten Text befolgt - die Fehlermeldung erschien nicht mehr - und gemäß Eintrag #3 das Update auf 3.3.0.16 durchgeführt. Beim Herunterladen in der Konsole blieb es zwar bei 99 % stehen, aber nachdem ich in der grafischen Oberfläche das Update nochmals angestoßen hatte, wurde der Rest geladen und das Update lief dann fehlerfrei durch.


    Ich hatte nach dem Zurückspielen der Repo-Dateien nach repos.d wieder die Fehlermeldung wie anfangs und habe die openrepos-llelectronics-Datei einfach radikal manuell gelöscht. Danach kamen bei "pkcon refresh", "pkcon update" und "version --dup" keine Fehlermeldungen mehr. Auch der Jolla Store und Storeman (nach erneutem Einbinden des llelectronics-Repos) funktionieren wieder.


    Vielen Dank für die Hilfe und die Mühe, die Du Dir bei der Fehlersuche gemacht hast!