Posteo.de - Kalender synchronisiert nicht mehr

  • Seit einigen Wochen fällt mir auf, das mein posteo-Kalender nicht mehr synchronisiert. Weder in die eine noch in die andere Richtung. Die ganze Zeit lief das problemlos.

    Ich habe jetzt versucht einfach den Kalender neu anzulegen. Jetzt komme ich gar nicht mehr an die Daten heran. Ich habe alle möglichen Kombinationen von Serveradresse usw. ausprobiert. Mit Slash und ohne …

    Kein der gefunden Anleitungen führt zum Ziel.

    Hat jemand eine Idee?


    1000...0 Grüße

    Daniel

  • Willkommen im Club :(


    Ich habe bisher auch vergeblich versucht SFOS (CardDAV + CalDAV) mit meinem Server auf meinem Localhost zu verbandeln. Dabei habe ich auch etliche Kombinationen von Serveradresse und Hostverzeichnis ausprobiert.

    dirksche hat mir dabei noch eine andere Kombi genannt - klappte aber bisher auch nicht. Heute abend will er das wohl selber auch nochmal ausprobieren.

    Mit dem Einrichten der 1.ten Allgemeinen E-Mail Adresse hatte ich ja auch schon dicke Probleme. Das klappte nur, wenn ich nach dem Einrichten direkt neu gebootet habe (Link). Irgendwas scheint da wohl nicht zu stimmen, oder ich bin zu blöd den Fehler zu sehen (denn meistens sitzt der Bug ja vor dem Gerät)


    -volker-

  • Hi,


    ich habe meinen Kalender am Xperia XA2 komplett neu aufgesetzt. Bei mir lag es daran, dass CalDAV unsauber war. Zugemüllt durch mich <X, schätze ich. Es zeigte bei den Konten bzw. bei Kalender verwalten noch Kalender an, die ich längst gelöscht hatte. Verbunden war das mit mailbox.org.


    Inzwischen bin ich mit einer Nextcloud-Instanz auf einem "eigenen" Server sehr zufrieden. Ich mache für die unsaubere Sache drei Dinge verantwortlich:

    1. Mich selbst - ausprobieren und so...
    2. mailbox.org - CalDAV schreiben wurde erst kürzlich für (öffentliche?) Kalender ermöglicht
    3. Jolla - so richtig perfekt ist CalDAV dort auch nicht. (Konten löschen, Nachfrage: Kalendereinträge auch löschen? oder so wäre nett bis professionell)

    Und die Kombination aus 2) + 3), natürlich. Nischen-Handy mit Nischen-OS bei einem Nischen-Mail-Anbieter.


    Das Bereinigen ist etwas Frickelei - aber möglich. Habe mich vor Jahren schon geärgert. Meine kleine Anleitung hier hat mir auch im Jahr 2020 nochmal gute Dienste geleistet. Wenn Du Dich also traust, frisch und sauber bei Null zu starten...


    https://gitlab.com/Frederik37/SailfishCalendarBackup

  • So, ich habe mir das auch mal angeschaut und festgestellt, dass bei mir Termine auch nicht (mehr?) richtig abgeglichen wurden. Da ich den Kalender fast nur auf dem Handy nutze, ist mir das bisher gar nicht aufgefallen. Folglich habe ich das Konto mal gelöscht und wollte ein Neues hinzufügen. Das ging aber nicht. Zumindest nicht, wenn ich CardDAV und CalDAV synchronisieren wollte. Nur CardDAV ging.


    Also habe ich mal ins TJC Forum geschaut. Dieser Fred hat geholfen. Falls du die Ports nicht angegeben hast.

    Versuche mal ein Konto für CardDAV und eins für CalDAV anzulegen. Bei mir war das die Lösung.

  • Die Ports hatte ich angegeben. Hab alles etliche Male angelegt. Nervigerweise muss man ja immer ein komplettes Konto anlegen. Ein Korrektur von Daten bei bestehenden Konten ist scheinbar nicht vorgesehen. Ich dachte eigentlich, dass die Kalenderschnittstellen standardisiert sind.


    Bei Posteo hatte ich alle Kalender gelöscht und einen neuen angelegt. Da hat es dann ein paar mal mit der Synchronisation bei Testdaten funktioniert. Als ich dann aber die Daten aus der Sicherung eingespielt hatte, hat nichts mehr funktioniert. Evtl. kommt Sailfisch mit zu vielen Terminen nicht klar. Zwischen Thunderbird und posteo funktioniert das gut.


    posteo hat sich bisher nicht gemeldet. Ungewöhnlich ...


    So wie es aussieht, scheint das nicht mehr zu funktionieren. Irgendwie fange ich an froh zu sein, nicht in ein neues Sailfishphone investiert zu haben.

  • Meine ersten Termine im Kalender sind von 2009, habe also 11 Jahre komplett - geht also. ABER, syncen mit Jolla bricht SF bei faulen Terminen OHNE MELDUNG ab. Liegen die Termine in der Zukunft könnte man meinen, es synct überhaupt nicht mehr. Auf dem XA2 habe ich auch mit 3.2.1.20 keine Probleme mit der Neueinrichtung von Konten (umständlich, ich weiß), als auch mit der Nutzung Bestehender. Das Jolla 1 tut es ebenfalls noch. Posteo habe ich allerdings gegen Radicale lokal eingetauscht und stelle keine Probleme fest.


    Probate Abhilfe mit Posteo seinerzeit : Termine aus Posteo exportieren und dort dann den Kalender löschen und einen neuen anlegen. In Evolution ebenfalls den alten Kalender löschen und neu anlegen (nutze Thunderbird nicht mehr). Dann den Posteo-Output in den frischen Evolution-Kalender importieren. Wenn alles wieder drin (und wundersam repariert!?) ist und mit Posteo abgeglichen, dann mit SF und einem frisch anzulegenden CalDAV-Konto synchronisieren und alles ist gut. Mit TBird habe ich das 2x tun müssen, deswegen habe ich das ausgemustert. Den Rat von makeixo, für Kalender und Kontakte jeweils ein getrenntes Konto anzulegen, kann ich nur zustimmen. Jolla hat da schon ewig ein Problem.




    Fazit: Auch andere kochen nur mit Wasser und Jolla täte gut daran nicht kommentarlos abzubrechen, sondern eine anständige Meldung auszugeben.


    Wie stelle ich fest, welcher Termin als letztes erfolgreich synchronisiert wurde?


    Dazu lässt man SF ein Backup auf die SD machen. Auf der gibt es dann ein File namens "sailfish_backup_datum_blah_blah.tar". Das kann man auf den PC kopieren und öffnen (Linuxer habens bequem). In einem der Verzeichnisse steckt die Kalenderdatei (all.icl), die man extrahieren und durchforsten kann. Das zeigt einem schon mal den letzten Termin, der noch geladen werden konnte. Der nächste dürfte ein korrupter gewesen sein. So kann man sich zumindest an die Stelle(n) heranarbeiten und ggf. PC-seitig korrigieren.


    Bildschirmfoto zu 2020-01-28 16-32-02.png




    Edit:


    Und ja, es ist ein Frickelsystem, aber zumindest mit einer Möglichkeit selbst Hand anlegen zu dürfen. Bei anderen heißt es "friss und stirb".

  • Na das Problem ist, dass kein Termin hochgeladen wird. Und wo nix ist, kann ich nix auslesen.


    Posteo hat wenig erhellend geantwortet:


    ... gerne versuchen wir, Ihnen zu helfen.


    Meines Wissens hat die Adressbuch- und Kalender-Synchronisation in SailfishOS diverse Fehler, weshalb eine Einrichtung möglicherweise fehlschlägt.


    Grundsätzlich ist diese aber wie folgt möglich: Öffnen Sie Einstellungen → Konten → Konto hinzufügen → CalDAV und CardDAV. Geben Sie die URL https://posteo.de:8443 ein und setzen Sie die Einrichtung fort, wie in diesem Hilfe-Artikel für die App DAvx5 beschrieben: <https://posteo.de/hilfe/kalend…vdroid-android#einrichten>


    Viele freundliche Grüße von Posteo



    Im Prinzip bin ich genauso schlau wie vorher. Irgendwie komisch, dass es Jolla nicht schafft eine solche Basisanwendung ordentlich zum laufen zu bringen. Besonders, wenn sie bereits mal funktioniert hat. Da es mit Thunderbird unter Linux seit "Urzeiten" funktioniert, wird das Problem wohl tatsächlich an Sailfish liegen.

  • Na, det is die crux mit den zentral verwalteten Konten. Funktionierte die Einrichtung in einem Programm nicht, konnte man ein anderes verwenden; wenn alle Programme auf ein zentrales Konto zugreifen, denn ist halt kagge wenns das nich tut.


    Die Möglichkeiten zu konfigurieren sind auch sehr eingeschränkt beim Jolla. Wenn ich mir das in meinem Evolution anschaue, dann wird da die Adresse umgewandelt zu:

    https://posteo.de:8443/addressbooks/user.name/default/

    für die Adressen bzw.

    https://posteo.de:8443/calendars/user.name/default/

    für Kalender. Du könntest - gerade, wenn du nur den Kalender verwendest - mal versuchen das in der Notation einzugeben, und schauen ob das klappt. Dann wüsste man, das SailfishOS die interne Weiterleitung von Posteo nicht rafft. user.name ist freilich durch deinen account namen (alles vor dem @posteo.de) zu ersetzen. Ich trau mich das nicht zu probieren, bei mir funktioniert es erstaunlicherweise (erstaunlicherweise weil ich gedacht hatte, das ich das abgeschaltet habe, ich brauche den sync kaum). Ich hatte das vor ewigen Zeiten (ich glaube noch unter SFOS2) eingerichtet und (vielleicht auch wichtig) CardDAV ist bei mir deaktiviert.


    Ich finde es schon erstaunlich, das Posteo sich überhaupt mit so einem Nischenproblem wie SailfishOS auseinandersetzt (zumal es wahrscheinlich mehr Probleme macht, als es user hat). Und das Jolla Fehler nicht gefixt bekommt, ist ja auch nicht neu. Aber deine Antwort zeigt mir wieder mal, das ich mit Posteo den richtigen Mailprovider ausgesucht habe. Das die nicht unser brokenOS fixen können, ist wohl offensichtlich.


    Und jetzt sach mal noch jemand, daß das KEIN Lifestyle ist, sich mühselig ein Betriebssystem auf ein entsperrtes Gerät zu flashen, damit man ein buggy OS hat, über dessen Fehler man dann in einem Forum beratschlagen kann. Es gibt echt Leute, die besseres mit iher Zeit anzufangen wissen.

    Zeit für einen Rotwein. 8o

  • Nun haut nicht so drauf rum. Ich kann Posteo auf dem XA2 problemlos einrichten. Man muss nur getrennte Konten für CalDAV und CardDAV einrichten. Ich versteh Euer Problem nicht so recht.


    Geht genau so wie beschrieben


    https://posteo.de:8443

    Username

    Passwort

    Pfad : /calendars/user.name/default/


    Kontotyp nur CalDAV


    Analog für Adressen mit Port 8843 !!!


    Steht doch hier schon im Forum wie es geht!

  • Ich habs gerade nochmal probiert auf dem X:

    1. Schritt: bestehendes schon eingerichtetes Posteo calDAV synct in beide Richtungen.

    2. Schritt: Konto gelöscht und nach 4carlos2 Anleitung neu eingerichtet. Synct, funzt, klappt, löppt!


    Achtet auf die Ports: 8443 ( Kalender) und 8843 (Adressen). Das lädt zum Vertauschen ein.

  • Ich habs gerade nochmal probiert auf dem X:

    1. Schritt: bestehendes schon eingerichtetes Posteo calDAV synct in beide Richtungen.

    2. Schritt: Konto gelöscht und nach 4carlos2 Anleitung neu eingerichtet. Synct, funzt, klappt, löppt!


    Achtet auf die Ports: 8443 ( Kalender) und 8843 (Adressen). Das lädt zum Vertauschen ein.

    bringt dennoch nichts, weil spätestens nach dem nächsten update dann wieder
    nichts gescheit funktioniert.
    So war es bei mir jedenfalls. Habe dann posteo gekündigt und verwalte den
    Kram nun per filoFax.
    Diverse Termine sind ein einfach verschwunden oder wurden erst gar nicht

    auf dem server geladen.
    So was ist doch Alles amateur-haft - wenn ich mit der icloud vergleicht, bekommt

    man ja mit dem sfOS Zeug die Mücken am Anus.


    Verstehe eh nicht, wie man eine der artige Grundfunktion bei Jolla nicht in den
    Griff bekommt ....

  • Ich habe jetzt alles noch einmal hin und her probiert. Alle Kombinationen die mir eingefallen sind. Nichts funktioniert. Da die Synchronisation mit Thunderbird unter Linux problemlos funktioniert, liegt das Problem wohl in den Tiefen von SFOS. Evtl. liegt es daran, dass ich noch das Jolla 1 habe. Das wird sich in absehbarer Zeit alleine durch die veraltete Androidunterstützung ins Museum verabschieden müssen. Demnächst ist wohl nicht mal der Firefox mehr unter Android 4.4 lauffähig.


    Mal sehen was ich mache. Aber meine Begeisterung für SFOS stürzt gerade ab. Hier und da etwas am System basteln ist nicht mein Problem. Aber wenn die Grundfunktionen nicht gewährleistet sind, dann kann man damit nicht produktiv arbeiten.

    Wenn man ein neues Gerät wenigsten auf Android zurückspielen könnte, würde ich es vielleicht nochmal ausprobieren. Aber im Moment für ein System Geld auszugeben, dass so wackelig ist und dann noch ein Handy verbraten? Ich weiß nicht, ob das Sinn macht.

  • Wenn man ein neues Gerät wenigsten auf Android zurückspielen könnte, würde ich es vielleicht nochmal ausprobieren.

    Ich dachte das ginge, allerdings unter Verlust der Kameraqualität.


    https://jolla.zendesk.com/hc/e…-reinstalling-Sailfish-OS


    Den Schritt wieder zurück zu SFOS muss man ja nicht machen. Hab es aber noch nicht versucht.


    Gruß

  • Man kann mich dem Emma Tool auch das Sony-Android wieder aufspielen. Ich sehe keinen Grund, warum das nicht gehen sollte. Die Frage ist, ob man das will. Beim Xx ist da so viel Müll vorinstalliert.

    Hast du eigentlich mal ein Factory Reset probiert? Bei mir funzt das auch wieder problemlos. Von daher kann ich mir nicht vorstellen, dass das am OS liegt. Frag vll mal bei TJC nach. Dort gibt es doch sicherlich auch einige die ein Jolla 1 haben.