[offen] Installation pyqt5 - "libpython3.4m.so.1.0 benötigt"

  • Hallo zusammen,


    möchte python-pyqt von https://openrepos.net/content/sailfishlib/pyqt installieren.


    Bekomme:


    # pkcon install python-pyqt

    Auflösen

    Änderungen werden getestet

    Fertig

    Schwerwiegender Fehler: libpython3.4m.so.1.0 benötigt von python-pyqt-5.1.1-1.armv7hl wird nirgends zur Verfügung gestellt



    Es fehlt also python3.4 - bei mir sind aber python3.3 und python3.7 installiert.


    Woher bekomme ich jetzt python3.4?


    Sailfish OS 3.0.2.8 (Oulanka)


    Danke und Gruß

    Nichtschwimmer

  • Hallo dirksche,


    danke, aber das habe ich schon probiert. Weil Python3.7 schon installiert ist, bekomme ich


    # pkcon install-local libpython3_4m1_0-3.4.6-12.3.1.armv7hl.rpm

    Dateien werden installiert

    Änderungen werden getestet

    Fertig

    Schwerwiegender Fehler: installiertes libpython3_7m1_0-3.7.2+git1-1.3.2.jolla.armv7hl macht libpython3_4m1_0, welches durch libpython3_4m1_0-3.4.6-12.3.1.armv7hl angeboten wird, obsolet


    Und Python3.7 deinstallieren geht nicht, weil dann allerlei weitere, von sailfish benötigte Pakete deinstalliert werden müssten. Das wage ich nicht.


    Also habe ich Python3.4 selbst kompiliert und installiert.


    Nun versuche ich, PyQt5 zu kompilieren. Also mache ich - nach entpacken -


    # python configure.py

    Error: Use the --qmake argument to explicitly specify a working Qt qmake.


    Also versuche ich, qmake zu installieren, und mache


    # pkcon search qt5-qmake

    Suche nach Details

    Software-Liste wird aktualisiert

    Abfragen

    Fertig

    Verfügbar qt5-qmake-5.6.3+git8-1.8.4.jolla.armv7hl (jolla) QMake


    Aber wenn ich installieren will, bekomme ich


    # pkcon install qt5-qmake-5.6.3+git8-1.8.4.jolla.armv7hl

    Paket nicht gefunden: qt5-qmake-5.6.3+git8-1.8.4.jolla.armv7hl

    Ausführung des Befehls fehlgeschlagen: Dieses Werkzeug konnte keine verfügbaren Pakete finden: Keine Pakete gefunden


    pkcon behauptet also nach search, qt5-qmake-5.6.3+git8-1.8.4.jolla.armv7hl sei verfügbar, kann aber nach install keine verfügbaren Pakete finden. Begreift das jemand?



    Danke und Gruß

    Nichtschwimmer