Versuch: Sailfish auf Sony Xperia X (F5121)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Das Problem ist, du hast höchstwahrscheinlich irgendwo einen Tippfehler, den wir nicht sehen.

    Gibt doch bitte nochmal

    Quellcode

    1. ./fastboot
    2. fastboot -i 0x0fce oem unlock 0x<insert your unlock code>

    ein und mach davon jeweils einen Screenshot. Den oberen Befehl hast du ja eingegeben. Der sollte funktionieren. Den unteren Befehl hast du noch nicht gepostet.
  • Also.

    Ich habe folgendes eingegeben:

    .\fastboot devices
    .\fastboot -i 0x0fce oem unlock 0x[MeinCode]

    Die Rückmeldung lautete:
    C:\Users\Frank\AppData\Local\Android\Sdk\platform-tools\fastboot.exe: unknown option -- i


    ---


    Danach habe ich folgendes eingegeben:

    .\fastboot devices
    \fastboot -i 0x0fce oem unlock 0x[MeinCode]

    Die Rückmeldung lautete dieses Mal:
    \fastboot : Die Benennung "\fastboot" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines
    ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern
    enthalten), und wiederholen Sie den Vorgang.
    In Zeile:1 Zeichen:1
    + \fastboot -i 0x0fce oem unlock 0x[MeinCode]
    + ~~~~~~~~~
    + CategoryInfo : ObjectNotFound: (\fastboot:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException


    Suggestion [3,General]: Der Befehl \fastboot wurde nicht gefunden. Er ist jedoch am aktuellen Ort vorhanden. Windows PowerShell lädt Befehle nicht standardmäßig vom aktuellen Ort. Wenn Sie diesem Befehl vertrauen, geben Sie stattdessen ".\\fastboot" ein. Weitere Informationen erhalten Sie unter "get-help about_Command_Precedence".


    ---


    dann der nächste Versuch:

    .\fastboot devices
    fastboot -i 0x0fce oem unlock 0x[MeinCode]

    und hier dann die Rückmeldung:
    fastboot : Die Benennung "fastboot" wurde nicht als Name eines Cmdlet, einer Funktion, einer Skriptdatei oder eines
    ausführbaren Programms erkannt. Überprüfen Sie die Schreibweise des Namens, oder ob der Pfad korrekt ist (sofern
    enthalten), und wiederholen Sie den Vorgang.
    In Zeile:1 Zeichen:1
    + fastboot -i 0x0fce oem unlock 0x[MeinCode]
    + ~~~~~~~~
    + CategoryInfo : ObjectNotFound: (fastboot:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException


    Suggestion [3,General]: Der Befehl fastboot wurde nicht gefunden. Er ist jedoch am aktuellen Ort vorhanden. Windows PowerShell lädt Befehle nicht standardmäßig vom aktuellen Ort. Wenn Sie diesem Befehl vertrauen, geben Sie stattdessen ".\fastboot" ein. Weitere Informationen erhalten Sie unter "get-help about_Command_Precedence".
  • Hallo MüderFrank,

    prinzipiell dürfte es egal sein, welchen Interpreter Du verwendest, aber nimm doch zur Vergleichbarkeit auf Win7 die alte cmd.exe aus C:\System\Windows\System32.
    Dann gehst Du damit ins Verzeichnis des entpackten Sailfish-Binaries und gibts für einen Screenshot ein:

    dir
    fastboot -h
    fastboot devices

    Dabei bekommst Du nach jedem der 3 Befehle eine Rückmeldung. Von den 3 Befehlen inkl. der Rückmeldungen bitte einfach Screenshots machen und posten.
  • Hallo Frank,

    die Screenshots sind aus dem Android-Verzeichnis, nicht aus dem mit den SFOS-bins.
    Ich weiss nicht, wieviel das Helpfile noch anzeigt bei Dir. "-i" ist bislang jedenfalls nicht dabei. Überprüfe doch mal Deine Version von fastboot mit "fastboot -version". Gehe aber dazu VORHER aus dem android-Verzeichnis heraus und in das Verzeichnis mit den entpackten Sailfish-binaries. Dort ist auch ein aktuelles fastboot dabei, welches Du verwenden solltest. Bei mir war es bspw. Version 26.0.0.
    Dort schaust Du dann nochmal mit "fastboot -h" nach "-i". Es sollte im helpfile enthalten sein (falls nicht, bitte nochmal screenshots mit dem Verzeichnis, also der Ausgabe von "dir", dann mit der Ausgabe von "fastboot -h", dann mit der Ausgabe von "fastboot -version". Alternativ holst Du Dir eine andere Version von fastboot aus dem Netz. Ich kenne jedoch nur Versionen, die die Vendor-ID mit -i akzeptieren. Gibt man also "fastboot -i" ein, so sollte korrekterweise die Beschwerde kommen: "option requires an argument"

    Sobald das der Fall ist kannst Du weitermachen wie in der Anleitung beschrieben.
    USB-debugging anschalten, Handy ausschalten, +Lautstärke-Taste gedrückt halten, während Du das ausgeschaltete Xperia X an den Rechner anschließt. Dann gegebenenfalls auf die Aufforderung hin den den richtigen android_winusb Treiber auswählen (in das entsprechende Verzeichnis lotsen). Kannst dann auch im Gerätemanager das neu eingetragene adb-device sehen.
    Dann sollte "fastboot devices" eine Antwort ergeben, sofern der Treiber richtig installiert ist.
    Und dann sollte auch "fastboot -i 0x0fce oem unlock DEINUNLOCKCODE" angenommen werden.
    Auch hier sollte eine fehlerlose Antwort kommen. Ansonsten wie immer: Screenshots....

    Vielleicht hat das weitergeholfen... Es ist bei mir einige Monate her und genau weiß ich das Vorgehen nicht mehr. Aber es war alles einleuchtend und hat auf Anhieb geklappt, ausser dass die Sony-Modifikation des winusb nicht akzeptiert wurde (stattdessen standard android usb-device).