Android Apps laufen nicht unter Sailfish X

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Android Apps laufen nicht unter Sailfish X

    Hei hei!

    Hoffe, in dieser Runde kann mir jemand helfen. Habe seit kurzem das Sony Xperia X und auch erfolgreich das Sailfish X installiert. Läuft soweit wie ich es von meinem alten Intex Aquafish gewohnt bin.

    ABER: Der "Store" für Android-Apps lässt sich nicht installieren (bzw. nach scheinbar erfolgreicher Installation nirgends öffnen - wird auch nicht in der App-Liste angezeigt) und scheinbar lasen sich auch keine anderen Android-Apps installieren. Der ganze Sinn der Sache - also Android auf Sailfish zu nutzen, ist damit hinfällig. Natürlich habe ich in den Einstellungen das Ausführen von Fremd-Apps zugelassen.

    Wäre sehr dankbar für Ideen/Lösungsvorschläge!
  • Ingojolla schrieb:

    habe die Lizenz von Jolla gekauft - bin mittlerweile auf eine mögliche Ursache gestoßen, habe nämlich die Lizenz über mein Jolla-Account erworben und am Xperia aber ein neues Jolla-Account für meine Frau eingerichtet. Möglicherweise liegt da der Hund begrabe. Werde mal versuchen, ob die Android-Unterstützung mit meinem Account funktioniert.
    Ja dem ist so, du kannst aber auch Jolla bitten die Lizenz auf den neuen Account zu übertragen.
    :D
    ninja
  • geändert habe ich das Konto (zu dem Konto über das die Bezahlung erfolgt ist) erst, nachdem Android nicht funktioniert hat. Habe dann während des Betriebes unter Einstellungen "Konto" das Jolla-Konto meiner Frau entfernt und anschließend meines hinzugefügt und aktiviert. Danach erstmalig neu gestartet. Im Anschluss war unter den Jolla-Apps der Android support neu aufgetaucht. Der Versuch diese zu installieren scheitert dann aber (die Installation bricht ab). Wenn ich das Konto wieder wechsle verschwindet die App wieder.
  • Du musst dich auf jeden Fall mit dem Konto anmelden mit dem die Lizenz gekauft wurde. Hast du die Sailfish Utilities drauf aus dem Jolla Store? Wenn nicht, dann mal draufpacken und in den Einstellungen suchen (heißt Hilfsprogramme) und da mal den Paketzwischenspeicher leeren.
    Dann im Terminal devel-su pkcon refresh && pkcon update eingeben und durchlaufen lassen. Dann versuch nochmal im Jolla Store den Android Support zu installieren.
    Du kannst es danach auch noch einmal über das Terminal versuchen mit pkcon install aliendalvik. Dann gibt's evtl. eine Fehlermeldung mit der man was anfangen kann.

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von dirksche ()

  • Ingojolla schrieb:

    geändert habe ich das Konto (zu dem Konto über das die Bezahlung erfolgt ist) erst, nachdem Android nicht funktioniert hat. Habe dann während des Betriebes unter Einstellungen "Konto" das Jolla-Konto meiner Frau entfernt und anschließend meines hinzugefügt und aktiviert. Danach erstmalig neu gestartet. Im Anschluss war unter den Jolla-Apps der Android support neu aufgetaucht. Der Versuch diese zu installieren scheitert dann aber (die Installation bricht ab). Wenn ich das Konto wieder wechsle verschwindet die App wieder.
    Man muss sich mit dem JollaKonto anmelden und angemeldet bleiben mit dem man die SailfishX Lizenz gekauft hat.

    Flash doch einfach nochma und melde Dich gleich mit dem Konto an mit dem die Lizenz gekauft wurde.
  • Erstmal herzlichen Dank an alle - ich komme schrittweise weiter aber am Ende ist es einfach nur zum Haareraufen!

    Nachdem alles gescheitert ist habe ich das System nochmal aufs Xperia geflasht, mit meinem Konto eingerichtet und siehe da, nun wurden Android support und store von Anfang an installiert und sind am Gerät vorhanden. ABER sie sind immer noch nicht in dem App-Raster und somit auch nicht aufrufbar!

    Mit den obigen Tips habe ich anschließend pkcon upgedatet und konnte auch aliendalvik installieren, die fehlende Datei wurde dabei installiert und ist nun ebenso vorhanden. Aber auch nach einem erneuten reboot bleiben die Android-Apps für mich nicht nutzbar und ich verstehe einfach nicht, warum das nun nicht funktioniert.... ;( ;( ;(

    P.S.: o.k. Store funktioniert nicht, aber ich kann jetzt endlich Android-Apps installieren - Aptoide aus dem internet heruntergeladen (das ging bis vor kurzem nämlich noch nicht) und darüber lassen sich nun alle gängigen Apps herunterladen und installieren!

    Also DANKE nochmal an alle - ich denke, so kann man's lassen!!!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Ingojolla ()