Neues PureMaps (Chum) wieder mit Sprachausgabe!

  • Die Hilfestellung brachte der Dev selber (Storeman / PureMaps) in dem er den Hint in den Kommentaren brachte, Librarys von Hand zu löschen. Denn ich hatte ja das Problem, das die Chum-Version von PureMaps unbedingt eine neue Lib brauchte - mein SFOS aber meinte das alles aktuell wär (Link).

    Ergo habe ich mein Puremaps deinstalliert (den OSM Scout Server mit der NRW-Mapdatei so gelassen wie er ist), 2 Librarys, ebenfalls mit Storeman deinstalliert (mapboxgl-qml 1.7.7 und qmapboxgl 1.6), neu gebootet und das PureMaps von chum installiert - welches nun fehlerfrei durchlief.

    Nun klappt auch wieder die Sprachausgabe.

    Falls ihr das nachmachen wollt, deinstalliert vielleicht erst einmal nur die mapboxgl-qml 1.7.7. Vielleicht reicht das schon.

  • Bei mir war die Sprachausgabe ab 4.4. einfach weg. Ab dem letzten update von PureMaps lief sie wieder ohne etwas zu deinstallieren . Die erste Version war vom Jollastore. Sprachpackete von Openrepos . Später Neuinstallation über Chum , da darauf hingewiesen wurde, dass die App hier aktueller gehalten wird .

  • Kannst Du mal sehen, so unterschiedlich verhalten sich unsere Phones. Ich hatte ziemlich lange (weiß gar nicht mehr ab wann) keine Sprachausgabe mehr bei Puremaps.

    Und bei der Installation über chum hat er einfach mit einer Fehlermeldung (brauche höhere Version oben genannter Library) abgebrochen.

    Und itoss hat das komplette System neu geflasht, und ein stummes Puremaps gehabt - trotz der Installation beider Text2Speech-Engines (dabei dürften bei einer Neuflashung des OS gar keine alten Librarys vorhanden sein).


    Aus diesem Grund bin ich mit meiner Navisoft ja umgestiegen auf Magic Earth - wollte aber die native Navi nicht unbedingt deinstallieren.


    Allerdings hat Puremaps zu Magic Earth immer noch einen entscheidenden Nachteil (jedenfalls bei mir):

    Die Mozilla-Standpunktdienste (die ungenaue Alternative zur Hardware-GPS) funzt dort anscheinen nicht. Bei Magic Earth habe ich sofort meinen (ungenauen) Standort - bei Pure Maps ist gähnende Leere. Ich denke mal, dass bei Pure Maps nur der GPS-Sync funktioniert. Und das dauert halt bei einem XA2+.

  • Ja, die Telefone sind wirklich nicht gleich . 32 bzw. 64 bit. Ich habe mein xa2ultra auf 4.4.0.64 angehoben und beim Browsertest über HTML5test wird beim 10 ii ein Scorewert von 495 und beim xa2 ultra von 450 angegeben . Aber das nur nebenbei. Er läuft auch auf dem xa2 ultra flüssig . Die Sensoren der xa2 Reihe sind aber bekanntlich nicht die besten. Der Double-Tap zum Aufwecken ging beim xa2 immer genau einmal nach dem Neustart . Beim 10ii anstandslos.

  • Aufgrund von QuasarMX hatte ich mein XA2 nochmal reflasht. und nun funktioniert alles bis auf SMS Versandt.


    ich bin folgendermaßen vorgegangen:


    - Handy reflashed und gestartet

    - Verschlüsselung eingerichtet

    - QasarMX installiert ( scheint sich nur EINMAL! installieren zu lassen ?! )

    - root Partition auf 6 GB vergrößert => https://speefak.spdns.de/oss_l…empartition-vergroessern/

    - zypper installiert

    - Chum Repo paket installiert und Chum via GUI aktualisiert

    - zypper ref und installation der Chum Pakete

    - /etc/sudoers Eintrag erstellt => echo "defaultuser ALL=(ALL) ALL" >> /etc/sudoers


    QMX installierte ich direkt nach der zypper installation mit zypper local und es lief. Bis auf den SMS Versandt läuft nun alles, ( PW mit picotts TOIN ) keine Versionskonflikte o.ä. .


    Zum Sync/GPS bei puremaps : Ohne eine andere GPS App verliert PureMaps die Position. Es scheint so als würde das GPS trotz laufendem Puremaps/Scoutserver in den Standbyschalten wenn keine andere GPS App läuft.

  • Zum Sync/GPS bei puremaps : Ohne eine andere GPS App verliert PureMaps die Position. Es scheint so als würde das GPS trotz laufendem Puremaps/Scoutserver in den Standbyschalten wenn keine andere GPS App läuft.

    Bei mir läuft automatisch - wenn ich den "Standort" starte (also GPS aktiviere) - die App GPSinfo mit (wird in der App Situation in der Abhängigkeit von GPS aktiviert).

    Das meinte ich aber nicht. Puremaps stört sich einfach nicht an den zuschaltbaren zusätzlichen (ungenauen) Ortungseigenschaften mittels /Standort/Individuelle Einstellungen/"Offline Positionsbestimmung über Mozilla-Standortdienst-Mobilfunkmasten"

    Hier in meinem Zimmer kann ich damit bei Magic Earth sofort meine ungenaue Position sehen. Mit Puremaps eben nicht (weil im Zimmer) - da sehe ich gar keinen Standort. Da aber natürlich auch die Hardware-GPS aktiv ist, wartet Puremap sturr auf diesen Sync (da kann er im Zimmer lange warten).

  • 5-10 Minuten "Bootzeit" gebe ich PM immer. WLAN Standortbestimmung traue ich nicht ( NSA is watching you ). Wenn ich Touren fahre und Stunden unterwegs bin machen 10 min auch nix mehr aus.


    PM weigert sich allerdings die deutsche Sprachausgabe zu aktivieren, es steht alles auf deutsch aber PM gibt nur englisch aus, Im Test menü kann ich PM auf Deutsch stellen und im test ist die ausgabe dann in deutsch - aber nur während des testens.

  • ...bei mir stand nach der Installation die Stimme auf männlich und ich hatte die weibliche Quasseltante. Dann habe ich von englisch auf deutsch gestellt und so war es dann auch.

    Testmodus: ok

    Routenmodus (Route berechnen lassen und Animation abgespielt): "Starte Navigation" (ohne GPS-Signal ging es aber nicht weiter - was ich aber nicht verstanden habe. Ist doch ne Simulation).

    Ich habe daraufhin mal auf den GPS-Sync gewartet um dann nochmal die Simulation zu starten. Wie ich vermutet hatte - daran lag es nicht. Die Tante wiederholt sich: "Starte Navigation" und weiter geht es nicht. Dabei habe ich bei der Simulation schon statische feste Start -und Zieladressen eingegeben (also nicht von "gegenwärtiger Position" mir die Strecke berechnen lassen). Oben im Header steht trotzdem "Position unbekannt".

    Fazit: Keine Ahnung, ob Puremaps tatsächlich funktioniert - ich müsste mich mal tatsächlich irgendwo hin navigieren lassen, aber irgendwie war Puremaps früher viel verlässlicher.

  • ...muss ja nicht bei Jedem so sein. Habe ja auch nur die Simulation bemüht.

    Das jedes Gerät anders reagiert habe ich hier bei dem Thread mit F-Droid gemerkt. Kappt, bis auf eine anfängliche Macke beim Update von F-Droid nun absolut fehlerfrei. Immer, bei jedem Aufruf.

    Demnach könnte bei Dir ja die Simulation bei Puremaps doch funktionieren.

    Die tabellarische Simulation (unter der Map / "in 300 Meter rechts" / "usw.") ist absolut vollständig.

    Simulationen sind eh überbewertet und Jollanutzer leidensfähig.