XA2 Update 4.2 --> 4.3

  • Leider wird das nicht behoben,

    Zitat

    Known issues to Android App Support 10 - Xperia 10 II, Xperia 10, and Xperia XA2

    • Sometimes, Android apps may not be able to use Internet connections via a mobile network. If there are connection problems later on (either WLAN or mobile data), stopping and starting the Android service at “Settings > Android App Support” should help. Toggling the connection off and on is another trick to try.

    obwohl, es steht ja da wie geholfen wird. :thumbdown:

    Sony Xperia XA2 mit LineageOS 18.1
    Sony Xperia XA2 mit SFOS in der Schublade

  • Leider wird das nicht behoben,

    Och, habe bisher nur den Anfang der Neuerungen für die 4.3 gelesen. Und da steht noch, dass es da einen Fix gibt:

    • A fix helping Android apps to connect back to a WLAN network (from a mobile network) added

    (Edit: Mist, jetzt habe ich das auch gelesen)


    Was ich aber auch noch interessant finde ist das hier:

    • Android system image is signed now. Many apps that previously complained of a rooted system work now.

    ...das würde mich für so manche entscädigen (Warden z.B.)


    Hier mal das Video von Leszek -> Link


    -volker-

    - Frickelphone (XA2 Plus mit Sailfish)

    - Lumia 930 (Windows Mobile 10)

    Einmal editiert, zuletzt von Volker S ()

  • Anscheinend musste jolla unter der Haube so viel im OS umbauen das es für ein eigenes Update gereicht hat. War wohl nötig um künftige Updates bereit stellen zu können.

    hier der Link dazu: https://jolla.zendesk.com/hc/e…6347?mobile_site=true#4.1


    Ich hoffe mal das ab sfos 4.4 wieder mehr sichtbare änderungen kommen. Das mit dem Browser-menü zum schließen find ich nicht schlecht.

  • Ich wollte gerade das Update machen. Da hat mich das System empfohlen eine Fotokopier-App zu entfernen. Und dann auch ein ofono-alien-binder-plugin. Die beiden Dinge könnten beim Update Probleme machen. Eine ungenutzte Fotokopier-App habe ich gelöscht. Hoffentlich die richtige. Aber was in aller Welt ist das für ein Plugin und wie kann ich es entfernen?


    LG

    Teletubbie


    Sailfish-ofono-mysterium.jpg

    Sony XA2, mit meist aktuellem SFOS 4 (also im Moment mal noch nicht ...)

  • So wie es aussieht, gibt es nur eine Lösung auf Systemebene. Das ist natürlich alles andere als Anwenderfreundlich. Dazu kommt noch, dass das alle keine »offiziellen« Lösungswege sind. Also keiner weiß, ob das im Ergebnis wirklich funktioniert.


    Ich warte einfach mit dem Update ab. Was soll ich sonst tun.


    In einem Forum habe ich jemanden gefunden der mir aus der Seele spricht:


    https://forum.sailfishos.org/t…uomenlinna-4-3-0/8495/240


    Achtung automatisch übersetzt:


    Wir haben mehrere Community-Antworten zu diesem Thema, in denen jeder einen Ausweg zu finden scheint, aber diese sehen alle wie fundierte Vermutungen aus (nichts für ungut: Wenn Sie es bisher geschafft haben, alle Probleme zu überwinden: Hut ab vor Ihnen!) Aber was ist der offizielle Ansatz von Jolla hier: Wie sollten wir Endbenutzer damit umgehen? Welches Paket sollte wirklich gelöscht werden und wie? Oder kann diese Meldung ignoriert werden? Die einzige Antwort, die ich finden konnte, war, dass wir diese Meldung vielleicht gar nicht erst erhalten sollten. Ich verstehe, dass manche Probleme seltsam aussehen und Zeit brauchen, um gründlich behandelt zu werden, aber ich würde zumindest gerne wissen, was zu tun ist:

    'Mach weiter und ignoriere die Warnung', 'lösche nur dies und/oder das, aber lass die anderen' oder 'mach nicht weiter, bis wir mit den Untersuchungen fertig sind'. Ich habe kein Problem mit all dem, aber es wäre schön, etwas in der Hand zu haben (vielleicht wäre es eine gute Idee, dies auch in die Hinweise für bestimmte Geräte zu packen - denn es scheint sich auf das XA2-Modell zu beziehen - des ursprünglichen Beitrags).

    Sony XA2, mit meist aktuellem SFOS 4 (also im Moment mal noch nicht ...)

  • Ich denke SFOS ist mittlerweile ein Betriebssystem für Fummler, Bastler, Freaks. Bei jedem Update bleiben "Kleinigkeiten" zurück die nicht oder erst viel später behoben werden. Eigentlich nennt man das Verschlimmbesserungen, äußerst schade.


    Ich hab das XA2 mit SFOS jetzt erst mal in die Schublade gelegt und benutze LOS als Smartphone OS. Da kommen die E-Mail und Threema Infos ohne das ich da erst gucken muss und das war/ist mir wichtig.

    Sony Xperia XA2 mit LineageOS 18.1
    Sony Xperia XA2 mit SFOS in der Schublade

  • Ich hatte ja dieses Mal (zum ersten Mal) auch diese Warnungen erhalten.


    Gott sei Dank waren das bei mir Jolla-Systempakete, die er als Störenfriede behandelte:


    glib2

    libselinux

    openconnect


    Ein Forenuser (Jolla) hat versucht diese Pakete zu löschen. Natürlich kam dann eine Warnung, dass er das besser sein lassen sollte. Dann hat er das mit Gewalt gelöscht und steckt nun in der Bootschleife fest.

    Ich finde es echt mittlerweile nicht mehr so lustig - da es diese Warnungen doch schon etwas länger gibt (nur ich habe sie nun zum ersten Male zu Gesicht bekommen).

    Dabei mache ich vor jedem OS-Update schön brav ein 'pkcon refresh' und 'pkcon update'. Danach wird neu gebootet und dann erst wird das OS erneuert (obwohl das OS beim Update ja selber Apps und Libraries updated).


    PS: Habe diesen eindeutigen Quatsch (lösche bitte systemrelevante Dateien) natürlich ignoriert und bin nun aktuell auf der neuen Versionsnummer. 'Warden' verweigert mir natürlich immer noch den Dienst, wenn ich einen Service einer App deaktivieren möchte mit 'no root'.


    ...aber ich glaube, dass ich da etwas in den falschen Hals bekommen habe. Es sollen ja jetzt Android-Apps starten, die sich vorher wegen eines gerooteten Gerätes geweigert haben zu starten (Banking-Apps). Das hat wohl nicht mit Warden zu tun.


    -volker-

  • also ich sollte folgende pakete deinstallieren :


    git-minimal

    gittin

    ofono-alien-binder-plugin


    tatsächlich deinstallieren konnte ich :

    git-minimal

    ofono-alien-binder-plugin


    gittin wurde nicht gefunden.


    git-minimal lies sich nicht mehr installieren (Paket wurde nicht gefunden )


    hab auch vorher pkcon refresh gemacht.


    Aliendalvik lässt sich nicht mehr starten und ist laut dem jolla -store nicht mehr installiert

  • Nein Nein, ich meinte schon die Android-unterstützung. Hab sie gerade aus dem jolla-store reinstalliert und ertaunlicher weise funktionieren die noch installierten Apps ohne datenverlust. :thumbsup:


    Das Schließen des Browser-menüs durch schieben gefällt mir. weniger das wehlende schiebe menü der tab-seite

  • ...also das ist ja schon echt derbe. Bei mir war das nur nach dem ersten Start inaktiv. Also zu dem Zeitpunkt, wenn das System direkt nach dem Update von selber startet.


    Beide Buttons waren aber nur ausgegraut (Anhalten und Starten) - es war also noch installiert.

    Nach einem Reboot des Handys war wieder alles normal.


    -volker-

  • bei mir leider nicht. Der button zum starten des delvik lies sich drücken passiert ist nichts. Erst eben nach der reinstallation war der wieder da.


    Frag mich was das los ist. Beim Update auf Verla war Signal hin, und jetzt der ganze dalvik.


    Hab gerade auch mal aus Spaß die ne Online-Banking App istalliert. Die läuft wirkliche ohne zu meckern... Und wieder weg damit.